Darkly Labs Community

WTF Connection and other issues

Hello Darkly Lab support.

 

I have to write, because I face not only one issue, I have to list is:

  1. USB connection

  2. WiFi connection

  3. Wavy lines

  4. Emblaser fan noise

  5. Controller firmware update

 

1) USB connection

I run with windows 8.1. I have to wait several minutes to connect. It always show “waiting for connection…”. I need to minimum plug-out/in USB three times to get connected. Once connected, it seems to work. But because of noisy fan during  Emblaser is idle, I need to switch Emblaser off and on regularly. So, I face this issue several times a day. It sucks.

2) WiFi connection

I got the wireless connection established, but it seems not very stable. If I remember correctly I was connected by WiFi and several times the laser job was just stopping and does not continue. Laser was still on with a reduced light - so there was no alarm, the  red enable LED was still on. It looks like wireless connection got interrupted. Similar thing I simulated with USB by just plug-off the USB cable and it shows same behavior. Finally WiFi cannot be used for Laser jobs.

3) Wavy lines

I realized wavy lines, which should be straight. I read all articles I found in darkly lab forum and other websites. It seems a popular problem without good workaround. I also reduced the speed to 800mm/min - just to see, that there are still waves clearly visible, which is from quality point of view NOT acceptable.

If not visible on picture so well, it is clearly noticable.

4) Emblaser fan noise

The fan is always running. I have read an article, that this is the case and cannot be disabled. Ok, I understand to run fan during Laser job and a while after. But because of fan is running in idle, I have to switch Emblaser off, because it is too loud. Therefore I run several times a day into point 1).

5) Controller firmware update

Mainly because of point 1) and 3) I want to update controller firmware to latest (current v126). I was not able to find out, which firmware version was previously installed. My device is from September 2019, but I got it delivered 3 days ago. Firmware update itself was successful, but after switch off and on, Emblaser was not detected by smoothyware drivers anymore.

image.png

“Emblaser Serial” is shown after controller firmware update, where smoothyware drivers are not compatible. The shown “Smoothieboard USB Serial” is hidden. I just made it visible - you see it is greyed-out. Before controller firmware update is was looking like that.

Also un- and re-install the same drivers, which were working before, will not work anymore. It shows in device manager, that the drivers were not installed (code 28). There are no compatible drivers available. After updating driver by selecting the .inf-file, the message comes, that the driver software for device is not found. So, no chance to get drivers installed as before.

image.png

I also uninstalled the device driver and right-clicked on driver v1.0 .inf-file to “install”, but now there comes NO “successful installed” message anymore. By trying driver v1.1 file there comes a successful message, but this version is not working for windows 8.1.  AND HERE I STUCK AND NEED MOST HELP.

 

I am a very patient person. But this list of issues are so annoying to me and give me the impression of a not very well-developed product. Sorry, I know it is, but you see my facing issues above.

@Darkly Labs: I need support. If we not find a solution for point 1), 3) and mostly 5), I need to send the device back as a last step.

 

best regards, Danilo

Hi Danilo,

I’m sorry to hear you are still experiencing issues with your Emblaser.

We will continue to assist you directly in your active support ticket, which has been updated to reflect the new points you raised above.

 

Best regards,

 

Lliam

Customer Support Team

D A R K L Y    L A B S

d a r k l y l a b s . c o m

Same issue here, but worse! I updated to 126 and the laptop I use to run the laser is Win 7. It won’t connect at all. I can run the laser from a Win 10 desktop in another room via wifi, but the wifi connection cuts out regularly for some reason. I submitted a ticket on this issue as well.

 

Note: I too see the “Emblaser 2 Serial” device in device manager with no driver attached and smoothie drivers do not work.

An additional issue that cropped up with the new version of lightburn as well: Reference the video. This is over wifi, its like lightburn is passing 1 line of gcode at a time and not buffering. The laser pauses routinely.

 

https://www.youtube.com/watch?v=sUzZjLMeOqc&ab_channel=MattJ

 

Hi,

We solved the Windows 7 issue in a recent firmware update available here. _ Note : you have to install it as per the exact method in the instructions for it to work._

I suspect this will solve the buffering issue, but let me know if it doesn’t and I’ll open a support ticket to assist you directly.

 

Best regards,

 

Lliam

Customer Support Team

D A R K L Y    L A B S

d a r k l y l a b s . c o m

Hi Lliam,

 

Unfortunately, that video was wifi connection to an Emblaser 2 (preorder model) using a Win 10 laptop. Thanks for the help on connection via USB for Win 7 though. Any idea why Wifi Win 10 is having the buffering problem?