Darkly Labs Community

Workspace Camera progress

Hi Lightburn, Domenic,

I had the same issue today after installing 0.6.06 and trying to calibrate the camera.
I’m happy to provide any information you need.

It also wasn’t able to detect the chessboard after the dots calibration.

 

Jeremy

@Cameron

I don’t think the console information is applicable to the camera. The camera is controlled by USB independently to the machine.

We have been able to get it working correctly in Windows, but as you have found, there is a Mac issue that LightBurn are looking into.

@Jeremy

What O/S are you using?

Is your camera appearing as ‘E2 Camera’ or ‘PC Camera’?

All this info is useful for us and the LB team to get the kinks out of the system.

 

Hi Domenic,

I’m running Windows 10.

It displays as “PC Camera”. It was one of the first machines off the line I believe.

Just to confirm the problem is that image displays small in the centre of the screen.

 

Jeremy

@Jeremy

That’s good info and will prove useful to the LB team. Thanks.


@Domenic, i am using windows, not mac. Latest surface pro with current version of windows.

and sound like gettin same resurlt as jeremy and joel

I believe this issue is related to the resolution the operating system is detecting the camera at. The original “PC Camera” and the newer “E2 Camera” should be able to achieve the same resolutions, but the firmware differences between the two may be causing the O/S to detect them differently.

We did all our testing with the ‘E2 Camera’, unaware there would be a difference.

LB are aware of this and working on a solution.

1 Like

I just attempted it again and while I was able to get the chessboard to be detected (a ceiling light was reflecting off the paper into the camera before) my screen looks the same as Cameron’s and Joel’s.

 

Jeremy

I am having same problems as Cameron, Jeremy and Joel.
Resulting image is only a small part of the checkered pattern as in those screenshots above.

I’m using a Surface Pro too.

Also, the “PC camera” seems to disconnect regularly and I need to switch to “none” or “front camera” (on the Surface Pro) and then back to “PC Camera” to start it again.
This makes calibration difficult

Interesting that we all get exactly the same resulting pattern since there’s no way they would be positioned in the same part of the bed on different machines.

only a bit interesting though.

I think this is a combination of issues - The firmware on older Darkly cameras defaults to a low resolution image, and the framework we use to access the camera doesn’t allow us to change the setting. I have purchased a batch of different cameras for testing, and have been able to reproduce this issue locally. I’ll be working to see what can be done about it from our end.

1 Like

It’s doing exactly what it’s supposed to - The image is being captured, the chessboard is found, and the image is rotated and aligned to position the chessboard in the dead center of the bed. That part at least is working as designed.

1 Like

Hm. I’m also on a Mac, also using what I think is the older version camera, but I’m getting a different problem: It doesn’t seem to be removing the distortion. Is this a bad calibration? I got 11 images of the dots, all at less than .3 error. 

p.s. Thanks for your work on this. I’m very excited to be able to start using up some of my smaller scrap material by being able to align them more accurately with the camera. 

 

The image in your workspace is not showing fisheye distortion, so that part appears to have worked correctly.

My suspicion is that the uneven lighting is preventing the software from finding the chessboard in the image, and so it isn’t able to compute the reverse-projection required to give you the overhead view. It also looks like your chessboard image isn’t flat, and that is also a problem - If the images are not *very* flat, the resulting maths won’t be as good as they could be.

It might be ok, but every bit of distortion in those images that *isn’t* from the lens is going to be treated as though it is, and will distort the final capture as a result. It may or may not be visible, depending on the amount of curve, but something you should be aware of. When calibrating here, our images are pasted onto foam-core.

Yep. That seemed to help. I got it to remove most of the distortion, but it only shows a portion of the workspace. That seems like the same issue the others were having, but it’s a great start. Thanks!

Hi Domenic/Lightburn,

Having the same trouble as the others, small image in the middle of the screen etc. My camera is listed as “PC camera” so I guess its one of the older types with the low resolution software.

My main sticking point is I can’t have my laser “On” to do the finale alignment. Since switching to Lightburn form laserweb my machines laser doesn’t idle like it did, is there a setting I’ve missed to enable that?

Thanks

@Timothy
Thanks for the info. This is a known issue and is being worked on.

With respect to having your laser ‘on’, there is no difference with how it behaves between LightBurn and LaserWeb. The low-power laser mode is actually controlled by hardware. You should be able to see the low-power beam when the lid is closed and machine enabled. Note, you may need to lower the laser head close to your material to see the beam focused enough to make out.

Hi Domenic/Lightburn,

As v0.7.00 was released a couple of days ago, decided to go through the Camera calibration again. This version shows several bugs in camera capture and chessboard sizing fixed.

On running the calibration I no longer get the small image of the chessboard in the workspace when I click ‘Get Chessboard’, instead I get a large grey square superimposed on the workspace.

The capture+calibration process appears to have been a success, with nine images captured with an average error of 0.07.

But I have adjusted/played with the Trace settings under v0.6.06 which may have an impact on my current results. If this is the cause could you please suggest a set of default values for the 4 variables in the Trace dialog ?

Thanks

If you’re referring to the width / height / offset values in the camera window, zero is the default for all of those.

If you mean the image trace dialog, I’ll have to double check on defaults for those, but from memory I think 2 (small item rejection), 1.0 (smoothing), 128 (threshold), and 0.2 (optimization) are correct.

The trace dialog wouldn’t cause a gray square on the main window - that’s a surprising result I haven’t seen before. What I’ll likely do is add some extra logging to the camera code to help track some of these issues. It’s hard to figure out what’s happening if we can’t reproduce the issue locally.