Darkly Labs Community

Trouble with wifi setup

I’m trying this a bit late, but I just updated my E2 controller firmware through Lightburn and tried to setup its wifi and update the firmware, but I’m getting an error after the scan: (none found). I’ve tried this on my home network and on the E2’s network (which I am able to join). Any ideas why the E2 doesn’t show up?  

Hi Nathan,

Can you tell me whether the Emblaser2 network appears in your WiFi list?

Have you connected to this network previously? If your E2 is successfully connecting to your local wifi network, then the Emblaser2 SSID will not appear anymore.

 

 

Hi Dominic, 

Yes, the E2 network appears in my wifi list. I can connect my computer to the E2 network, but that’s about it. The machine doesn’t show up in the wifi scanner device list. 

Hi Nathan,

Once you have successfully connected to the Emblaser 2 network once, it should never appear in your list again. From then on, it will automatically connect to your network when switched on and not broadcast the Emblaser 2 network.

The Emblaser 2 network only appears if your machine is unable to automatically connect to your wifi network.

Can you check you are using the correct password etc

 

 

Hey Dominic, 

I haven’t been able to enter a password; there’s no interface at all. I can select Emblaser2 from my list of networks, then the signal strength icon shows that I’m connected, then… nothing. 

When you are connected to the Emblaser 2 network, can you try and open a browser and type in this IP address:

EDIT:

192.168.4.1

It should bring up this screen allowing you to enter your credentials.

 

Nope, no luck: 

I will raise a support ticket for this and organise to get your controller board back to examine.

@Domenic @Nathan I believe that there is a typo in the IP address, it should have been this one: 192.168.4.1

Thanks, Kirill! I was able to connect through that address. I’ve successfully update the wifi firmware and have connected to the Emblaser2! This promises to be a huge improvement for my workflow (and my back, since I won’t have to sit on a tiny stool next to the machine to work on other projects)! 

Thank you, Kirill, and thank you, Domenic! 

Kirill, nice pickup.

Nathan, Great news.

I have fixed this mistype in the reply for anyone else who reads this discussion.

I cannot connect to the wifi

 

I went through the process and entered the correct password. Emblaser 2 doesn’t show up in the wifi menu anymore which is correct. When add the device no device is found. Is there an update I need perform?

One test to perform is to use a program such as ‘AngryIP’ to scan your network and see if the Emblaser is shown with an IP address. The machine will appear as ‘vendor: espressif’.

 

I’m having an issue as well. I’ve been able to connect to the Emblaser network, added my router details and password, the Emblaser network disappeared, but Lightburn cannot find the device. I downloaded Fing on my phone - also connected to the same wifi network - and all my other devices appear EXCEPT the Emblaser. 

I presume myconnection to the wifi is correct since the Emblaser network disappeared. 

What else can I try as I’d really like to be able to use this over wifi.

Thanks!

 

Linda,

Can you please confirm that you were not able to locate any device with a vendor id of  'espressif’

 

Hi Dominic,

That is correct. Here is a screenshot frm my phone (with the IP addresses removed). This is what my device list shows while the Emblaser is turned on.

Can you identify the DC B6:CD:45 device?

 

Yes, that’s my laser printer.

 

Linda, we have created a support ticket for this issue and you have been contacted directly.

We have found a bug in the software which was not looking for all possibilities of the Emblaser machines. This has now been corrected and will be included into the next LightBurn update (after 0.9.04)