Darkly Labs Community

Only one move with "Fire" activated, then nothing

Several versions ago, Lightburn was changed, “to help Ortur lasers”, but it broke the positioning behaviour for my Emblaser Core. The bug was acknowledged, and I’ve reported it each subsequent version, but nothing is being done. :disappointed_relieved: The issue is that I cannot turn on the laser at low power, then jog the head into position. I only get ONE MOVE, then I have to reset the communications. I’m reduced to moving the job, rather than the laser, or firing, ONE MOVE ONLY, turning Fire off then on again, then ONE MOVE ONLY…it got highly frustrating ages ago. Hopefully as Emblaser manufacturers, you may be able to enquire about this intoduced issue, as my feedback as a user is being ignored.

Hi Andrew,

Thanks for posting on the Darkly Labs Community site!

I’m sorry to hear that you have encountered this issue since an update. Thank you for bringing this to our attention. I have contacted LightBurn and will let you know if this is something they are able to address.

 

Best regards,

 

Lliam

Customer Support Team

D A R K L Y    L A B S

d a r k l y l a b s . c o m

Hi Andrew,

LightBurn have indicated that they may resolve this in an upcoming update. However for now, I have identified a workaround that should allow you to use this functionality until the issue is resolved.

_ WARNING: Using the ‘fire’ command bypasses the safety systems of the Emblaser. Do not leave the laser ON when unattended and be cautious of letting the laser sit in the one position when the laser is ON._

_ Important Note: To turn the laser off, type ‘ fire off’  or ‘ fire 0’ in the Console tab._

To workaround this issue, you can type ‘ fire 3 ’ in the Console tab and press ENTER. This will fire the laser at 3% power - You can replace the ‘3’ with any number below 100. Using the fire command this way will allow you to fire the laser at 100% power, staying below 20% power is recommended.

The fire command in the Move tab is limited to 20% power. The Console  tab does not have this restriction.

 

Best regards,

 

Lliam

Customer Support Team

D A R K L Y    L A B S

d a r k l y l a b s . c o m

Hi Andrew,

I just heard from the LightBurn team. The issue preventing you from being able to do more than one ‘move to’ operation with the Fire command when using the button in the Move tab is resolved in LightBurn 9.24 (currently in pre-release).

You will be able to use the [Fire] button once more after the next update, which should be available in the coming weeks.

  • Lliam

Thanks Liam,

the “Fire” in the console worked just the way it used to! I’ve missed that functionality SOOOOO much!

I did wonder when I read the response, if you could have included the command to un-Fire the laser, or how it could be turned off once the head was positioned, but I found that Fire-ing in the Console, then switching to the Move tab to position the laser, then clicking the “Fire” button twice (once for LightBurn to think it’s on, then again to turn it off) worked.

Thanks again.

Andrew

Hi Andrew,

Thanks for picking that up - I’ve added a note incase anyone finds this later.

Glad everything is working once more!

 

  • Lliam

NOTE: This bug was resolved in LightBurn 9.24