Darkly Labs Community

Leather knife sheath

Going small…the motorbike is 9cm x 5cm   power 50, min 0 FRC 25% skip white background, FR 4000 pixel r= .09

2 Likes

Thats looking great - love the spokes being visible, I guess thats thanks to the small pixel resolution you used.

Great work!

Caroline,
Was this create using picengrave pro and picsender? I started out with simple text and logo engravings using cut2d/Vtransfer (results were great). As you know, I have recently tried some photos using picengrave pro/picsender and now having trouble getting good results from any of the above. I’ve noticed some of your work was done using cut2d. Have you had any trouble switching from picengrave and cut2d? Darkly and picengrave have been very helpfull with my isssue. Sure seems like my troubles began when I started using picsender. Wondering if you have had any issues.
Thanks,
Mike

1 Like

hi mike, sorry to say i havent had any trouble with any of the programs.  In fact i love PEP so much, i use it when i could have used Cut2d.  In picsender, i dont change any settings.   Open,  H to home laser, Load…send.  If you are having problems across all software…i would think hardware.  First i would think re focus the lens…next the tension in the rubber strap pulley things. Also I recently found that the straps had slipped off their proper runners in two places.  And yes, support from Darkly and PEP is excellent.  cheers

1 Like

Hi Michael

I agree with Caroline, the picsender suite is really good and the support is almost immediate if you have an issue  (darklylabs support too. BTW). First thing to check is hardware issues, such as belt tension or the flatness of your material.

 

Materials can very wildly, especially organics like leather and wood. I’ve been trying a new source of 6mm ply, one side engraves  fine,so I  turn it over and try the same job and it caught fire… (I’ve never had THAT happen before!)

Another example if I may - I engraved a picture into plywood and it cut into the wood about 1mm… So next I thought I’d try doing the same picture in that textured lumpy  paper from art shops. I used the same file (ie same settings)  just as a  first pass, assuming that since it cut into ply then it would be a bit overkill for paper but I’d go from there, , but I just got a faint brown shadow on the paper…

It is a learning expereince…

 

1 Like

Thanks! Been trying to straighten this out for a week. Reassembled emblaser twice. Uninstalled and reloaded software 3 times. Anyway, I loved cut2d and vtransfer, it was working great. I make wallets and a few other items with my logo and some text. I mostly use laser for outlining (light power) my leather so I can then cut out. I found it great for marking lines for stitching holes as well for wallets. With cut2d I was able to mark lines and engrave logo all in one shot. It was quick as well. With picengrave, laser moves throughout entire area in diagonal lines even if there is just a few lines and small logo which takes a lot longer. Is there a way to get picsender to send cut2d file so it only engraves lines and logo. In other words, the laser would move along line when engraving. Hope that makes sense? I can post some pics this evening. I would love to use only one gcode sender.
Thanks
Mike

Hey mike, i think i know what you want picsender to do, but probably beyond my understanding of the program. I think you can set picsender to only travel a specific X and Y distance, rather than the whole area.  Any time i have messed with the settings i had the laser banging up against the rails.  Maybe ask the question over on the PicSender section.    Of course getting Cut2d to work again is the solution.  These sorts of software problems drive me crazy.  I would probably try loading cut2d and vtransfer on a different PC if u have one. One that has never had picsender on it.   It sounds like something is conflicting, corrupted, or some pc update did something.  Maybe your file has got corrupted somehow…try a fresh download? cheers  caroline

Hi Mike,

If your laser engraving B&W logos, Dither the image in the editor (Atkinson), set the Max at your full desired laser power and set Min at zero so the laser only pulses on/off. In the Analog/PWM engraving profile, select the Skip White Bkgnd. That will optimize the laser travel by ignoring the white areas around the outside of your logo. Also set the feedrate higher then engraving a grayscale image and set a higher Feed Rate Change percentage. Example: If you set the Feedrate at 150IPM with a 50% FRC, the laser will travel at 150IPM in white areas and slow to 75IPM to burn the black areas. These features in PicEngrave will reduce the overall engraving time.

I recommend you use PicSender for both PicEngrave & Cut2d L gcode files. Remember the startup block $N0= setting I had you write down and then change to another value? That change may cause a work place zeroing conflict issue when using Vtransfer. The default $N0= startup block value sets the X&Y work zeros at same place every time (lower left corner) you connect to the com port and Home your EmBlaser. The zeroing instructions I gave you will set the X&Y zeros anywhere in the work area and they will be saved in grbl when Exiting PicSender and set at the same place when reconnecting to the com port & Homing again.   

OMG, now i fully understand FRC…thank you jeff…and i also know i dont understand anything in the second paragraph…but dont need to at this stage.  

Jeff,
Regarding first paragraph above…In process/settings above, would laser still travel diagonally across full image. using cut2d and vtransfer the laser would engrave lines staying on the path of lines. Then would engrave logo.

Regarding homing… can u tell me what the initial $NO= value was? I did not write that down:( I believe this was when my problems began. I changed that value and then went back to cut2d and vtransfer. When that did not work I went back to PE pro and PS. By then every time I sent file using picsender the laser would bang up against sides when sending file and when homing. Could I load emblaser default values using picsender, would that restore the $NO= value to its original value? My original reason for changing that was that I wanted to use inches for photos. I can use mm from now on.

Thanks!

On a side note,
Problem seems to be vtransfer and/or picsender changing default values on the emblaser. I’ve tried using separate pc, one with cut2d/vtransfer loaded and the other with PE/PS. Had same issues. In a perfect world I would like to be able to use cut2d/vtransfer for marking and logos (most of what I do) and PEpro/PS for occasional photo engraving. I read in another post with similar issue that the user was able to do this by entering do command $10=3 into PS before exiting PS. They were then able to use cut2d and vtransfer with no issues. They were using later versions of the programs however.

Jeff,
Makes sense! I will do above this evening and let you know.
Thanks!

Jeff,
I have crv file saved from cut2d. This file has my wallet template which contains my cut out and stitching lines measured exactly. I can’t load a crv file into picsender. What would be the best way to keep these measured lines in this template and save as jpeg or file type that picsender can use?
Thanks
Mike

Mike,

You have to generate a gcode from that CRV file in Cut2d to Load and run that in PicSender. There should be a post processor you can select in Cut2d to generate the gcode for the EmBlaser’s grbl.

Is the post processor within cut2d or separate software that I need to download?
Thanks

Didn’t Cut2d L come with a Tutorial or a Help menu? 

Jeff, 

Well… making some progress.  Fixed bumping and homing with do command you recommended.    Ran test job of u.s. flag below.  Engraving is only 90mm wide.  I was very impressed with detail in the stars which are only about 2mm wide.  Problem is the wavy parts in some of the lines.  This was the 3rd actual test because the first 2 started with same wavy lines at beginning of engraving so I stopped it because  I thought it may be a blemish in leather but you can see some other areas in engraving are also wavy.

The second pic below is my wallet template in cut2d .  Please excuse all the practice engravings.  The darkest line is this job and defects shown by red arrows.  I saved toolpath in cut2d to emblaser processor which saved as .nc file.  I then loaded file in picsender and sent.  Again, the lines are wavy in places and some corners are not connected.  The laser did run the job following the lines which I thought would give straight lines.  Aside from the way laser burned, everything ran as expected until I tried running this same file again.  Second attempt to run same wallet template file below, laser went to about middle and started burning hole in same place and red alarm flashed continuously.  I had to cut power to stop.  There was an error “feedrate not set”.  Not sure what happened on second try.  Only thing I did after first try was home laser and click send.  I copied and pasted .nc file below. 

Again, Can’t thank you enough Jeff for all your help.  Hope to get this straight soon and I’ll leave you alone!

image.jpg

 

image.jpg
( Generated with Darkly Labs PP v2.4)
( File name: lines14perc )
( File created: Thursday June 08 2017 - 10:03 PM)
( Material Size: X= 300.000, Y= 200.000)
( XY Origin for Material = Bottom Left Corner)
( XY Origin Position = X:0.000, Y:0.000)
N60 G21
N70 G00 X128.221 Y14.398
N80 M3 S255
N90 G1 Y80.193
N100 G1 X37.221
N110 G1 Y14.398
N120 G1 X128.221
N130 M5
N140 G00 X138.632 Y10.149
N150 M3 S255
N160 G1 X139.045 Y9.907
N170 G1 X139.468 Y9.681
N180 G1 X139.902 Y9.470
N190 G1 X140.344 Y9.274
N200 G1 X140.796 Y9.095
N210 G1 X141.256 Y8.931
N220 G1 X141.723 Y8.782
N230 G1 X142.196 Y8.649
N240 G1 X142.675 Y8.532
N250 G1 X143.160 Y8.431
N260 G1 X143.649 Y8.345
N270 G1 X144.141 Y8.274
N280 G1 X144.636 Y8.220
N290 G1 X145.134 Y8.181
N300 G1 X145.633 Y8.157
N310 G1 X146.132 Y8.149
N320 G1 X146.632 Y8.157
N330 G1 X147.131 Y8.181
N340 G1 X147.629 Y8.220
N350 G1 X148.124 Y8.274
N360 G1 X148.616 Y8.345
N370 G1 X149.105 Y8.431
N380 G1 X149.590 Y8.532
N390 G1 X150.069 Y8.649
N400 G1 X150.542 Y8.782
N410 G1 X151.009 Y8.931
N420 G1 X151.469 Y9.095
N430 G1 X151.921 Y9.274
N440 G1 X152.363 Y9.470
N450 G1 X152.797 Y9.681
N460 G1 X153.220 Y9.907
N470 G1 X153.632 Y10.149
N480 M5
N490 G00 X152.630 Y14.431
N500 M3 S255
N510 G1 Y80.226
N520 M5
N530 G00 X153.632 Y84.300
N540 M3 S255
N550 G1 X153.220 Y84.542
N560 G1 X152.797 Y84.769
N570 G1 X152.363 Y84.980
N580 G1 X151.921 Y85.175
N590 G1 X151.469 Y85.355
N600 G1 X151.009 Y85.519
N610 G1 X150.542 Y85.667
N620 G1 X150.069 Y85.800
N630 G1 X149.590 Y85.917
N640 G1 X149.105 Y86.019
N650 G1 X148.616 Y86.105
N660 G1 X148.124 Y86.175
N670 G1 X147.629 Y86.230
N680 G1 X147.131 Y86.269
N690 G1 X146.632 Y86.292
N700 G1 X146.132 Y86.300
N710 G1 X145.633 Y86.292
N720 G1 X145.134 Y86.269
N730 G1 X144.636 Y86.230
N740 G1 X144.141 Y86.175
N750 G1 X143.649 Y86.105
N760 G1 X143.160 Y86.019
N770 G1 X142.675 Y85.917
N780 G1 X142.196 Y85.800
N790 G1 X141.723 Y85.667
N800 G1 X141.256 Y85.519
N810 G1 X140.796 Y85.355
N820 G1 X140.344 Y85.175
N830 G1 X139.902 Y84.980
N840 G1 X139.468 Y84.769
N850 G1 X139.045 Y84.542
N860 G1 X138.632 Y84.300
N870 M5
N880 G00 X164.786 Y80.193
N890 M3 S255
N900 G1 Y14.398
N910 G1 X255.786
N920 G1 Y80.193
N930 G1 X164.786
N940 M5
N950 G00 X140.446 Y14.431
N960 M3 S255
N970 G1 Y80.226
N980 M5
N990 G00 X260.133 Y10.195
N1000 M3 S255
N1010 G1 Y84.445
N1020 G1 X32.984
N1030 G1 Y10.195
N1040 G1 X260.133
N1050 M5
N1060 M5
N1070 G28

There is no feedrate set in that gcode file. You missed a setting in Cut2D.

http://www.picengrave.com/Pic%20Programs%20Page/PDF%20Files/misc/Understanding%20Gcode.pdf

You may need to run this test on your EmBlaser.

http://forum.darklylabs.com/index.php?p=/discussion/119/calibration-cutting-file

The belts may need re-adjusted and causing wavy lines.  

 

I will check belts tonight. I definitely did not miss feedrate. It was set at 400mm. It was set at 400 the first time and I changed it to 600mm and tried it the second time when it did not work . Now every time I send a file goes to middle and flashes red. I will reload software again and emblaser defaults.