Darkly Labs Community

Laser height

I seem to have a problem where the laser height adjusts to the highest possible setting no matter the material height I put in, or the calibration value I enter. This means the laser is far too unfocused to cut.

 

I’m thinking this is a software problem since I’m able to move the laser up and down manually in the “Move” tab.

 

See a video of what I’m experiencing here: https://drive.google.com/file/d/1Uz51VhUqG84VMBNsZFxtdQT8OdYBStt-/view?usp=sharing

 

 

Thoughts?

Hi Mac,

That is very unusual since it appears to be moving in the opposite direction than it should be in both instances.

Can you please confirm that when you first turn on the machine the z-axis homes all the way up.

Also, when you home via LightBurn, it homes the z all the way up as well.

Hello!

 Z axis would be the laser height?

If so, yes, it does bring the Z access all the way up on startup, if I’ve brought it down manually before shutting it off. 

Below is a screenshot.

 

Can you try the following:
1: Let me know what value you have set for your calibration?
2: Immediately after homing, go to the ‘console’ menu and type G0Z0
This should move the laser unit down to the lowest position. Please confirm
3: Save out and email me your LightBurn project. info ‘at’ darklylabs.com

Comments below in CAPS.

 

Can you try the following: 
1: Let me know what value you have set for your calibration?    RIGHT NOW IT’S SET TO 10. IV’E TRIED SETTING THIS ALL DIFFERENT VALUES TO NO EFFECT.
2: Immediately after homing, go to the ‘console’ menu and type G0Z0 
This should move the laser unit down to the lowest position. Please confirm    THAT WORKS. WHEN I CUT DIRECTLY AFTER RUNNING G0Z0 IT SEEMS TO MOVE TO AND CUT AT THE CORRECT HEIGHT. HOMING RETURNS TO THE HIGHEST ELEVATION THO.
3: Save out and email me your LightBurn project. info ‘at’ darklylabs.com   DONE.

 

Another thing I’ve noticed that may be related to this is that if I position my cut in the middle of the work space in Lightburn, the laser starts cutting almost at the very top left corner… it’s like the laser doesn’t know where it is… 

What is your “Start From” set to? If it’s “current position” (or “user origin” and you’ve never set one) that would be why it cuts everything in that corner.  Use “Absolute Coordinates”.

Homing does always return to max height. Clicking “Home” doesn’t go to zero, it runs the homing cycle, bumping off the limit switches.

Do you have a material thickness value set when you run a cut?

Mac,

1: The calibration value is an offset used for the z-height only. 

If your calibration card shows the thinnest line being #3, then this value needs to be entered as the calibration. This will ensure that your laser is always perfectly focused onto the surface of your material, regardless of the material thickness.

Entering 10mm as you did, will just result in the laser being out of focus.

 

2: That’s great. This is correct behaviour and shows your laser height is moving correctly.

The laser will always return to the maximum height after homing or completing a job. This is to ensure the laser is clear of any material in the workspace as it moves.

3: You LightBurn project file looks correct. It appears you are using 5.3mm thick material, have the cutting mats in place, are moving the laser at 798mm/min and have the power at 100%.

 

Please check the questions in the previous commend asked by LightBurn. They will help us get closer to resolving your issue.

 

 

Guys,

 

Consider this issue solved.

 

The following two settings fixed my issues.

 

1.  Setting the “Support (mm)” setting to 0.0.   I didn’t realize this was the “floor” height, and without the cutting mats (which are 10mm high) the laser was too high.

2.  Setting “Start from” to “Absolute Coords”.

 

Really appreciate your help!!

Excellent!

Thanks for letting us know.