Darkly Labs Community

Laser head not working

We solved the homing problem but now the laser fan or laser light isn’t working. We’ve pulled and put back in the FFC strip but nothing is fixing the problem. The gantry is moving ok with a file so it’s talking to the mother board but the laser itself want work. What’s happening?

Looking at old forum posts it says the FFC cable would cause this problem. In fitting it into the laser head how should it be seated? Because ours is not bent almost 90% from the clip then into the FFc seat is that right?

 

Is that the way the FFC cable should be in the laser head?

Is it common for the FFC cable to break at the laser head?

 

Maria,

Is this a new machine and you have never had the laser working or was it up and running and just stopped working?  It appears from your picture that the FCC cable is not inserted fully into the laser head printed circuit board.

It’s a new machine the laser was working. We’ve had the machine a week so really hadn’t done anything with it but yesterday we retensioned the belts then had homing problems fixed that but now the laser want work. So you say that by the pictures you think the cable isn’t inserted properly? How should it look? No matter how it’s put it want work now. The way it was before it was bent between the clam and the FFC housing should that be? We actually think the FFC is broken. But can’t understand how the laser head can be jogged and moved but the laser fan pr beam want work now.

Here’s a pic of how mine looks and I’m pretty sure that’s how the instructions say it should be installed. I don’t think it should be plugged in on an angle like your pic shows.

Another fairly common cause of the laser not working is the safety shroud on the front of the laser not being properly in place and depressing the micro switch on the left side of the laser unit body.

here’s a pic of how it is now the same as yours so why is our laser head not working now?

Is the micro switch on the left front of the laser unit being depressed by the laser guard?

yes that’s all fine. The fan laser was working as on Friday I calibrated the machine then did some basic engraving of words and it worked fine. We had to retension the belts and after that the laser fan nor the beam will wok. I’ve taken out and put back in the FFC cable at the laser head so many times now. Will look at it once more at the mother board just to make sure.

 

Are you sure the fcc cable is inserted fully? Not sure what else to suggest.

as far as I can tell yes it is fully inserted 

it going was bad ffc connection at mother board next time we no to check