Darkly Labs Community

First time run issues with LightBurn v0.6.01

Hi LightBurn Team,

I have a few questions on getting LightBurn and my Emblaser 1 operating correctly on my Mac running 10.13.3. Pictures attached.

1.) Under Devices Button - When setting up my Device, I am not offered a choice on the origin of my laser - they are greyed out. Is this ok?

2.) My Emblaser 1 is not Auto detecting from the USB port. I have to manually select a port, in this case cu.usbmodem1441 (not sure why it has this name). When I restart LightBurn it does not save this preset and resorts back to (Auto). I then have to select the above mentioned USB port to find the Emblaser 1.

3.) In the Move Panel, my device homes correctly and will stop when the limit switches hit the desired stop, however, when I hit the move arrows, the limit switches do not have an effect on the move which causes my laser to hit the edge and perform a hard jump/skip.

4.) When I quit LightBurn and restart LightBurn, if I do nothing but Click the Laser Position button from the left toolbar then click anywhere on the work surface, my laser slams into the sides of the unit. I am guessing it’s not recognizing it’s in the home position and thinks it’s somewhere else. So I’m finding I have to Home the machine before each and every use. Again, not sure why it’s not recognizing the limit switches are depressed.
Sidenote on this: When the laser is slamming into the edge, the Pause and Stop buttons do not work and I have to wait for it to find the position.

Thanks,

Ken

 

image.png image.png

 

 

 

 

 

 

  1. Origin is greyed out because the origin is in a fixed / known location for this machine.

  2. Emblaser 1 does not auto detect because it uses the same USB ID as lots of other devices, and we don’t want to send random data to anything you might have connected. We could store the last used port, and retry with that one if available. I can add this to the wish list.

  3. That will be a machine configuration issue, not a LightBurn issue, so I’ll have to let Darkly / Domenic answer that

  4. Do you have anything odd set in your config, like a work offset? The click-to-move feature only allows coordinates that are within the known workspace of the machine, so that is the safest / preferred way to jog. If using that tool is causing your laser to exceed the page limits, you may have chosen the wrong machine size.

1.) Sounds good.

2.) I get it. And +1 for adding to wishlist.

3.) I’ll wait to hear from Domenic.

4.) So I’ve reenacted my steps and moved the laser to the center of the work space for safety. The Click-to-move features works fantastically when the device has been HOMED. However, if I do nothing but turn on the Emblaser, launch LightBurn, and click to connect via USB, THEN, click and use the click-to-move feature WITHOUT HOMING, it thinks that the ‘home’ is the lower left of the work surface as I’ve shown in the image attached. The reason it was hitting the side of the machine in my previous experience, was the laser head was already sitting in the upper right home position of the work surface.

Also, any comment on the Pause/Stop not working during the ‘click-to-move’ process?

 

We may need to set the Emblaser 1 to auto-home on startup.  The E2 does this by itself, but I suspect the E1 does not. The laser does not know its position on power up until you home it, so this is expected behavior.

Regarding Pause / Stop - Pause may wait for the current command to finish executing, but stop should be immediate - it sends an abort to the controller, so it should be very quick to respond. I’ll double check on our end that this is correct.

Correct, the E1 has to be homed by pressing the home button to establish a known position.  This has always been the case regardless of what sender software is used.

I’m not having positioning issues, I’m having power issues. I correctly did the wire change, updated the firmware, downloaded the software, added the license, and started using LightBurn. I tried cutting some text at 20 mm/second and 80% power…but got nothing. Laser lights and I can see it firing while traveling around the path, but the text did not burn. I turned the power up to 100% and got very little. Thought maybe I had a dirty lens, so I installed a spare new one and focused it. Tried making 3 simple circles and burning (but not cutting through) on 3 mm plywood. Started at 10 mm/sec and 20% power, kept retrying and raising the power but not changing speed). Did not even start to mark the ply until at 90% power, but the laser did not burn a clean line, it would burn a couple of mm then nothing for the next several mm, then a little burning, then not…Tried all the way up to 100% power and 10 mm/sec, but still could not get a consistent line. Any thoughts; would relish any advice. Thanks.

In the console in LightBurn, type $$ and hit enter.  Your controller will emit a bunch of settings strings.  Tell me what the following values are:

$30
$31
$32

They should be
$30=1000   (this is the highest power value emitted by LightBurn, so these need to match)
$31=0  (possibly higher, but a low number - this is the firing threshold of the laser)
$32=1  (this enables laser mode)

If your numbers are different, you can enter the $30=1000, or $32=1 commands in the console and hit enter. That will set it in the flash, so it’s persistent.

Todd,

If your E1 was working OK prior to the update then check that the generated Gcode files are setting the power levels correctly.  

  1. Set up a simple job such as a square in LightBurn.

  2. Set power to 100%  doesn’t matter what speed.

  3. Save the Gcode file.

  4. Open the saved Gcode file in a simple text editor such as Notepad.

  5. In the first line of text you should read S1000  (1000=100% power) 

  6. If this is correct then look elsewhere for the issue.

 

 

Whoops…sorry Lightburn…I submitted my post not noticing yours had been posted whilst I was typing.

 

Not a problem at all - Honestly quite happy to have the help.

Will give it a try and report back. Thanks for the advice.

 

Timbr Design,

The homing switches are purely used for the homing process, to determine the initial position of the laser-head.

They will not prevent you from asking the laser to run into the side or go further than it physically can If you ensure you keep your designs within the LightBurn workspace, you won’t have any problems.

‘Homing’ the laser is required when you first turn on your machine. As LightBurn mentioned, he can have LightBurn automatically perform the homing process when it connects to the Emblaser1, but that may have to wait until the dev team get to it.

In the meantime, it’s always good habit to ‘home’ your machine when you first start it up.

Entered $$. The settings for 30-32 are correct. Tried burning a few more words. Picked Monotype Corsiva from the drop-down at random. At anything less than 100% power I still am not getting anything; at 100% and 10 mm/sec, I get burning, but still get stippled letters. At 100% and 5 mm/sec, I get connected laser lines, but I also get a ton of heat bloom. Something just doesn’t seem right.

 

 

There are a few specific issues here that make it difficult to debug via this discussion.

I have created support tickets for each user and we will deal more efficiently one-on-one.

We can then report the solutions back here in case others experience the same issue.