Firmware update fiasco

Hi Guys,

I attempted to update from (I think it was) firmware v.1.26 to v.2.xx with no luck. Lightburn now shows “disconnected”.

Typing “Version” in the console does not show anything.
Reboots don’t work.
Unplugging and replugging (including USB cable) doesn’t work.
Did a System Restore to before the firmware attempt but I didn’t expect it to fix firmware and of course it didn’t.
The Console showed “LB Upload failed”. Do not power off ……” within moments of starting the update.
I tried to update at least 4 times, then became desperate and attempted to update and iconnect by WiFi. No luck, I’ve never previously sorted out WiFi so have always ignored it.

I’ve run out of ideas and can’t get my beloved Emblaser to talk to LB.

Being a failed firmware update have I totally f***** up?

Hi Elayne,

I have just replied to your support request via ticket #4245.
Please let me know if you continue to have any issues.

~ Lliam

Hi Lliam, wow you work late! No luck at all. Was hoping I had a corrupted .bin but have tried 2 fresh downloads and attempts with no luck. Can’t think what else to try, beyond dark thoughts. :frowning:

Should I attempt to downgrade firmware?

Having trouble replying via email (ticket 4245) - it ain’t my day. :disappointed:

Thanks Lliam, I just discovered your reply and don’t want you to think that I am ignoring you. Recently I had to remove the back plate to check for a clogged fan and it took me one and a half days to remove and replace it, due to my severe arthritis. I’m don’t have anyone else nearbye to help so it will take me some time. I’ll get back,to you ASAP.

How do I budge the 4 Philips? screws holding down the PCB? I have removed one and budged another but it is just twirling in its hole and it is not coming out. The third is impossible to budge and I haven’t tried the fourth. I’ve used an electronic Arrowmax whose biggest bit is a Phillips 1, and I’ve tried 3 other drivers of varying sizes, all to no avail. I’m worried that I’m chewing up the heads.

Any suggestions?

LATER: I’ve removed three of the stubborn, four screws, but the fourth one down in the USB corner, totally eludes me. The head is now chewed up enough that I doubt that I’ll ever get it out. Can I contemplate drilling it out with a DREMEL?

EVEN LATER: am giving in, for the night. The errant screw has a chewed up head and also looks loose in its hole but just won’t budge. I tried using a thick rubber band on the driver head, and then tried attaching a screwdriver with a drop of superglue but the glue just wouldn’t set. (suggestions from iFixIt)

I’m thinking that I might be able to cut through the plastic/resin corner with a Dremel and then attack the screw from underneath. Is that feasible?

WEDNESDAY MORNING: Plans 3 or 4

Plan 3
I thought I’d order a pair of screw extraction pliers from Amazon:

However, there may not be enough room to fit the jaws in, without disturbing the “traces”.

======

Plan 4c

Why don’t I leave the stuck screw PCB where it is and attempt to remove the SD card by cutting a slot opposite it, through the casing? Possible problem: is it possible that the vibrations of a Dremel could open solder?

I too can’t get the firmware update to work . All I get is:
Waiting for connection…

ok

ok

------------------------- Starting firmware update Do not power off your E2 or disconnect

ok

binary uploading to file: /sd/firmware.drk

LB: Upload failed

(Lliam, I’ve been having intermittent issues with my mail - both in and out - and don’t appear to have received a reply to my yesterday’s mail to you so am duplicating it here)

Lliam, the good news is that I formatted the SD card and reinserted it. Now for the bad:

Disaster looms

I ever so carefully reattached all connectors, with the exception of the ribbon cable. I watched several videos which cautioned me to take extreme care with the procedure and ensure that all of the pins pressed in at once, not from side to side, so I knew what I needed to do.

Despite that, after half an hour of very gentle probing trying to find where the pins felt that they wanted to fit, I finally felt confident and placed pressure on them but realised that they were not right. Attempting to remove them revealed that the left corner (from my angle) was firmly stuck and did not want to budge. No amount of ever-so gentle pulling helped and it was only with extra force that I was able to remove the ribbon. The pins may or may not be damaged but the plastic sheeting certainly is and I am assuming that there is little point in connecting the machine, only to find that nothing works.

Do I have anything to lose by a further attempt (although I’m guessing that the white sheeting will stop the pins from mating), or would there be a fire risk? Assuming nothing works, I am guessing that at the very least I will need a repair, and then the further agony of fitting up and connecting a new ribbon cable.

I despondently await your response.

Elayne


Hi Elayne,

Oh no!
There is very little danger of further damage to the components, and almost no chance of fire by attempting to re-connect the FFC (Flat Flexible Cable) as is.

I do recommend laying the FFC on a clean flat surface, laying a pencil across the cable, just above the exposed traces, then with light pressure, slide the pencil over the traces and off the end of the cable. This should help to flatten any bumps that may catch in the connector.

Once re-connected, If there is an issue it will likely present in one of the following ways:

  • Homing Failure (False Trigger detection)
  • ‘Alarm lock’ Error due to no/intermittent sensor communication
  • Z-Motion intermittant or reversed
  • Laser Unit Fan intermittent or non-functional
  • Laser intermittent or non-functional

Please let me know how you go. If it’s still not working, we can arrange a repair.

Thank you, thank you!

Is the process to put the update on the SD card available in the forum anywhere? I’d really like to do the update…

Hi Brett,

If you are still able to connect to your Emblaser, I recommend simply retrying the update from the wizard, ensuring that you are unzipping the download and selecting the ‘firmware.bin’ file when prompted.

Otherwise, the process is as follows:

  1. Remove the SD Card, see: Emblaser 2: How to Access / Remove the SD Card
  2. Insert into a card reader/PC and format to FAT32
  3. Download and unzip the ‘E2 Firmware v210.zip’ file from here: Emblaser 2: Firmware
  4. Open ‘E2 Firmware v210’ and copy the following files to the SD Card: ’firmware.bin’ and ‘on_boot.gcode’
  5. Eject the SD Card from the PC
  6. Reinsert the SD Card into the Emblaser.

Hi Elayne,

Does that mean you got it working…?

Blockquote Does that mean you got it working…?

Sorry Lliam, just thanking you for offering me a possible option.

LATER: the good news is that I didn’t get any of your 5 possible error codes.

The bad news is ………

Well, actually there isn’t any!:joy:

Lliam, you are a bloody champion.! Thanks to your patient hand-holding I just now cut a 10mm circle in 3mm ply. I even managed to fairly easily replace the screws holding the back on ……

…… and I’m not going to mention that this ol’ grandma :older_woman:t2: managed to embed yellow paint from an Aldi carpenter’s pencil in between the ribbon cable pins! I was certain that it would spell the end to any chance of the Emblaser working and couldn’t believe it when s/he fired up first go. Phew!

Thank you, Lliam, as always.

1 Like

Ok Elayne,

We need to talk about you becoming one of our repair agents!

1 Like

Blockquote

We need to talk about you becoming one of our repair agents!

Blockquote

Domenic, If the new 10W can manage to cut a replacement set of fingers to replace my gnarled arthritic ones it sounds like a bonza idea. LOL

Hi Lliam,
Just wouldn’t update over wifi so copied the files to the SD card and worked like a charm…

Thanks…