Darkly Labs Community

Everything is broken!

So I did the firmware update on my eblazer 1 everything went nice and smooth with no errors

I started up LightBurn and saw the following

  1. Moving the laser is acting weird. Up moves up. Left moves right. Down moves left etc

  2. My laser no longer turns on ¯_(ツ)_/¯

The light is on but the laser remains off.

Irfaan,

I’ve been working through similar issues. So far what has worked for me with the wiring, is the short wire has to be RED, BLUE, GREEN, BLACK on the cream end per instructions, but the long wire has to be BLUE, RED, GREEN, BLACK. Then the arrows work perfectly. This goes against the recommendations from Darkly, but until I hear otherwise, this has been working perfect for me.

Hope this helps.

Ken

When you say the laser no longer turns on - do you mean, at all? As in, if you set a cut with a non-zero power value and run it, the laser doesn’t turn on for this?

Thank you Ken. Will try it and

I mean the laser doesn’t seem to power up ¯_(ツ)_/¯

The red LED is on on the bord but the laser isn’t powering up (so no blue beam/light visible)

I have a bad feeling something went wrong (probably with the emblazer firmware) and it fried my laser

How are you telling it to power up the laser? By default, the laser is off, right? It should only turn on if you do something specifically to turn it on, like using the “Fire” button (which must be enabled in the device settings) or running a cut. If you haven’t done either of those things, I would not expect a visible beam.

Irfaan,

I am just as new to this as you. I’m not sure if you are in a similar situation as me, but as the LightBurn commentator said you do have to ‘tell it’ to cut. 

The main thing I didn’t realize is you have to assign ‘burns’ from their library to layers.

Check out this video and step by step instructions. In my case, I simply wanted to do a test, so I chose paper instead of plywood. The setting was SPEED 13.3 and power 100% and it burned a nice top etch in a piece of pine. It was a hooray moment!

Hopefully, this helps:

https://darklylabs.zendesk.com/hc/en-us/articles/360000026936-LightBurn-Lesson-1-Spirograph

You can make it cut easily without using a library setting. Draw a simple circle on the page, and you’ll notice an entry in the cut / layer list on the top right. Select that, and it shows the power and speed settings for the cut. I believe the defaults are 20% power, 100mm/sec.  Lower the speed down to, say 10mm/sec.  Then hit “Start” and watch it go. You can access more cut settings by double clicking the entry in the cut / layer list.

Irfaan,

I have created a support ticket for you on this issue. It will be easier to work directly with you to have it resolved.

Rest assured, it is not possible that any firmware or software change can physically damage your laser.

 

Thanks for the answers guys

From what I’m now understanding is that the laser behaves differently on the new firmware.
In the old firmware I was able to turn on the laser with a long press where the laser defaults to minimum power, this was also achieved by removing the laser guard and then pressing and holding the button down to go into focus mode (laser runs at like 10%) so you get to see the small blue dot that you can then focus by eye
This no longer works at all

Perhaps the firmware changed this behavior

I haven’t been able to try and cut tho because of the complication with the laser movements. Since the laser can’t move appropriately, every time I try and home it or run any simple cut, the laser tries to move out of bounds and just bangs into the E1 walls

I am going to follow up with the support ticket and revert back with any solutions :slight_smile:

Happy cutting everyone
( Aside from me (ツ) )