Emblazer 2 Firmware Update

I am trying to update an Emblazer 2 from v123 to v210. It continues to give me this message.
Starting firmware update Do not power off your E2 or disconnect


binary uploading to file: /sd/firmware.drk, send control-D or control-Z to finish

Rename/move of firmware failed


uploaded 315792 bytes


Build date: Jun 25 2018 10:01:06, MCU: LPC1768, System Clock: 100MHz

E2 Firmware v123

I have tried multiple times. Any suggestions?

Hi Ruth,

Can you please try the ‘Updating Old (Pre DL123) Controller Firmware’ process listed here: Emblaser 2 / Core - Updating Firmware

Please let me know if you continue to experience any issues.

Okay, I will try this. Although, the current firmware is at v123. My Emblazer 2 does not show up as a Flash Drive. Ruth

Hello, still no success. I have version v123 and no external drive shows up for the Emblaser so I cannot drag any file onto it. I tried to upload v126 to see if it needed that before going to v210 but it would not take it either. I tried renaming v126 to just firmware.bin but still wouldn’t take it. This is the message I get. I also cannot connect it to wifi although I went through the steps and joined the emblaser wifi with my laptop. Please help.

Starting firmware update Do not power off your E2 or disconnect


binary uploading to file: /sd/firmware.drk, send control-D or control-Z to finish

LB: Upload failed


uploaded 315792 bytes

Hello, I am still unable to update the firmware or connect it to wifi. I am not sure if these issues are connected. Please help. I posted on the community. Ruth

Lliam, can you offer any suggestions. Ruth

Hi Ruth,

It sounds like there may be any issue with your SD Card. Can you please try the following steps:

  1. Remove the SD Card, see: Emblaser 2: How to Access / Remove the SD Card

  2. Insert into a card reader/PC and format to FAT32

  3. Download and unzip the ‘E2 Firmware v210.zip’ file from here: Emblaser 2: Firmware

  4. Ensure the file is unzipped, then open ‘E2 Firmware v210’ and copy the following files to the SD Card: ’firmware.bin’ and ‘on_boot.gcode’

  5. Eject the SD Card from the PC

  6. Re-insert the SD Card into the Emblaser.

Please let me know how you go with the above.

Can I use a Macbook to do this process or does it need to be a PC?

You can use a Mac or PC, as long as you can connect the SD Card to the computer either directly or with a card reader.

Okay, I will be back in work tomorrow and check it. Thank you. Ruth

Alright, that appeared to update the firmware when I now ask for the version in Lightburn. Can you also assist with getting it on the wifi?

Great, so you can operate the Emblaser via USB, normally?

To set up the Emblaser for use over WiFi, you will need to follow the steps outlined in here: Emblaser 2 / Core - WiFi Setup using AngryIP

Please note that USB connecting is recommended to reduce the likelihood of drop-outs mid-job.
You will also still need to connect via USB to perform the Focus Calibration process.

If you have any issues connecting please send a screenshot of the AngryIP search results as well as the WiFi menu on your computer (located in the Menu Barat the top of the screen on a Mac, or the System Tray section of the Task Bar in Windows) to: help@darklylabs.com.