Darkly Labs Community

Emblaser2+LightBurn WiFi support

Hi there,

Is WiFi support for the Emblaser2 working in LightBurn? I have tried adding a new Ethernet/TCP device using the IP address of my Emblaser2 (it was successfully configured to connect to my home network), but the Laser tab shows ‘Disconnected’.

The current wifi will work with LightBurn just yet.

There is a new version of the WiFi firmware that we are doing final testing on and it will be released with the updating instructions soon.

There are also some extra features being added into LightBurn to help locate WiFi connected Emblasers.

 

Thanks, that’s great to hear. Looking forward to the new firmware!

Any update on this firmware’s progress? Did I miss it?

 

From Lightburn 0.7.04 onwards there was an option to find/update Emblaser WiFi devices, so I tried that and followed the wizard to upload the new firmware. This allowed me to cut from a WiFi connection.

image.png

I haven’t had much time to really test reliability. Initial impressions were that it works, but it might be a bit unstable, depending on your WiFi signal.

In my case, homing the axes or moving the head via the Move tab sometimes wouldn’t work. It’s almost like the Emblaser dropped out from the local network and couldn’t re-establish a connection to my WiFi (I had to restart the laser+lightburn). However I have yet to experience a ‘wireless’ cut stalling midway due to a lost WiFi signal (maybe because the gcode data stream kept the network connection alive?), but like I said, I haven’t had more time to work on the laser. Perhaps others could share their experience here?