Darkly Labs Community

Emblaser2 can’t connect with USB

I have installed firmware and software as per instructions.

Haven’t changed any cabling since using laser web half an hour ago.

Emblaser2 shows up in the Devices drop down box.

But it’s always Disconnected and I can’t jog or update firmware again.

Any thoughts?

1 Like

Hi Tom,

Can you click on the button that shows (Auto) and ensure your Emblaser 2 is listed in the list.

You can then select it from that list and it should connect.

 

image.png

no, there’s no options there.

What O/S are you on?

If windows, can you check your Emblaser is being recognised and assigned a port via the Device Manager?

Can you restart LB, with the Emblaser 2 still on and check whether your machine port appears in the list?

Can you confirm you copied across the firmware.bin file to the SD-card and also the on-boot.gcode file and waited for them to complete before turning off the machine?

HP mini
Windows 7 Starter
Service Pack 1
32 bit

Drivers for Smoothie Serial are not installed according to Device Manager (code 28)

Yes I copied both files over and confirmed to replace existing.
They’re tiny. Pretty sure I didn’t shut it off before they’d copied over.

Installing LightBurn should not have made any changes to your installed drivers, since you were previously running LaserWeb successfully on this computer.

Can you try to re-install the drivers for Windows 7.

I will check with LightBurn to see whether they have seen this happen before.

 

We haven’t, no.  (Following the thread)

Does the SD card still mount when you power the Emblaser? If so, try copying the files over again. If it doesn’t show up, check the drivers as Domenic suggested. If it still doesn’t mount, try running LightBurn again.

One of the changes made to the firmware was that the SD card no longer mounts to the PC (this was a source of issues on Mac computers). If the card doesn’t mount, it would suggest that the firmware did update.  LightBurn itself doesn’t do anything with system drivers, so I can’t imagine that being the source of any problems.

Windows can’t find the Smoothie Drivers

When I try and install Lightburn I get a dialogue box asking me to
“Repair or Remove Microsoft visual C ++ 2010 X 86 redistributable to its original state

Could this be anything to do with it?
I have been checking the repair button, maybe I should be checking the remove button?

Did you download / install the 32 bit version of LightBurn?  (Does it have “32-bit” in the name?)

SD card doesn’t mount like it used to.

Can’t see it anywhere in my computer with the hard drives like it did before

Yes, 32bit version

Just tried the other one now and it wouldn’t let me, saying it was for 64bit machines.
(That one should probably have 64bit in the file name)

Where can I get the smoothie drivers?

(thanks for the help)

 

https://darklylabs.zendesk.com/hc/en-us/articles/115005817867-Emblaser-2-Drivers

 

Smoothie Driver V1.1 doesn’t work because that’s for 64bit

I’ll try v1.0

 

 

 

 

 

Smoothieware.inf wasn’t recognised as a driver software for Smoothie Serial
Windows didn’t ‘detect’ it

 

Tom,

In case the firmware was not copied over correctly, can you please follow this article to remove your SD card and then insert it into a computer to repair?

https://darklylabs.zendesk.com/hc/en-us/articles/115007852828-Replace-Emblaser-2-SD-Card-Rev1-0-

Once you have the SD card out, insert it into a computer and check it is still working. You can also reformat it as fat32 and copy the two firmware files over again, just to be safe.

 

OK Thanks Domenic, I’ll try that.

I have also uninstalled and let it reinstall the Smoothie Serial device and also uninstalled Lightburn and reinstalled it with no luck.

During installation of LightBurn I got the option as usual to Repair or Remove Microsoft Visual C++ 2010 Redistributable. I removed it this time, but no change

 

We’ve done this, and it’s surprisingly easy. You’ll need  way to connect the MicroSD card to your computer, so either a USB reader or SD to MicroSD adapter. Make sure you have such a thing first. They come with every GoPro or sport camera, and often come with MicroSD cards themselves, and can be had from Amazon for a few dollars.

What I’m thinking is that if you copied the files over to the E2, but didn’t “unmount” or “eject” the card from the computer before powering off the E2, it’s possible that the files were corrupted. Windows occasionally does things like virus scanning, file indexing, or things like that to be “helpful”. If it was in the middle of an operation like that when the power was turned off, it’s possible for a file to corrupt. If the E2 attempted to boot from such a corrupted file, it would be Bad™.  But it is straightforward to fix, albeit inconvenient.

 

That redistributable library is needed, so if you get the option to install it again you should. You can also try installing from Micrsoft’s own version of it:

https://www.microsoft.com/en-us/download/details.aspx?id=5555