Darkly Labs Community

E2 Laser position in LightBurn Workspace

Prefacing: LightBurn is an outstanding piece of work and and very nice to work with (After some Library re-calibration…) on the Emblaser 2.

 

Not sure if I’m missing something here, but most of what I do when playing lasers involves cutting small pieces from reused stock, where LaserWeb showing the current laser head location was incredibly useful for positioning the part - jogging the laser into the right spot and using that to move things around as appropriate.

 

LightBurn doesn’t seem to do this - I have no indicator of where the laser head currently “is” on my workspace. The E2 homes correctly, LightBurn happily reports it’s correct, using the ‘Set laser position’ works as expected, jogs are fine, moving a part to laser position works, there’s just no indicator. :frowning: There is a red dot at (0,0) (Origin?) and a green dot at machine home (300,0). Issue existed in both 0.5.1x and 0.6.01

 

What am I missing here?

 

Incidentally, I’m having (presumably unrelated) SVG import issues with LightBurn, where’s the best bug report location?

If your import issues with SVG are images, this is known, and support for embedded images is in progress (and very nearly complete). If it’s text, it needs to be converted to paths prior to export, because we don’t support all the possible options that can be applied to text in packages like InkScape at this time.  If it’s something else, please forward the file to developer at lightburnsoftware.com and we’ll have a look.

Apparently you’re missing the ability to display the laser head position in the edit window. We don’t actively query for that for fear of interfering with the communication thread, but it wouldn’t be terribly difficult to show the last known position of the laser head if you use Get Position from the Move window, or the Click to Jog feature.

We have a way to fire the laser at low power, and this can be used to align your jobs, but it was only very recently added, and hasn’t been enabled for the E2 profile. (I’m turning that on now).  At about 1.0% it makes a nicely visible, non-burning bright spot that can be used when running a frame command.

That said, the E2 has a dimmer spot active by default when the laser enable button is active which serves this purpose well.  Does this, plus the frame command, not work for you?  Ultimately, since you have to look at your material to determine whether or not it is aligned, having an indicator in the viewport seemed unimportant. Using the click-to-move button while clicking various locations on your artwork in the view should quickly tell you if it is aligned.

This will be in the next release:

image.png

The position of the indicator (shown above, upper left) will not update in real-time, only when “Get Positions” is clicked, or the Click to Move tool is used.

Thanks for your reply!

 

The import issue is more about some of my SVG imports being all over the place. Either the exports from FreeCAD or the edits from Inkscape, some elements are … wonky, and in the wrong spot, or missing It seems to open OK in something else (i.e. Internet Explorer). Exporting to PDF and importing them to LightBurn yields an expected result. I’ll make some screengrabs and forward them and the source on.

 

Correct, just being able to display where on the edit window the head last was would be perfect. The E2 dimming mode is what I use in conjunction with jog to get it in the right spot on the lacework of veneer scraps, but then I’ve kind of lost where I was on the grid. I don’t really care while it’s cutting, but being able to see where it’s at after a jog, click to jog, or clicking the Get Position would be ideal. I’ve never really used frame, having had poor experiences with it in previous software, and my parts are small and often scattered where I have space on the veneer. I’ll have a play with it and should be able to get by, but if you’re looking for features to add to LightBurn… :smiley:

The feature looks perfect, thanks! (If it could update on clicking the jog buttons too that would be even more perfect, but that’s definitely workable).

With the jog buttons we could do it - We’d have to query the device first to know the current position, and add the distance manually. Waiting for the query to return would affect the interactivity a bit which is why it’s not done that way already.  I might try it to see what kind of impact it has.

Was having similar positioning trouble as you too Drew. Was thinking that laserweb used to have a round red dot that showed the position of the laser during cuts and amazed at how much I miss this, as used it to pause or stop cuts in between elements of a job. Now I endlessly stare at the laser as its burning to stop it in the right spot and fear that it will make me go blind like watching welding can damage eyesight.

Was going to query myself if we could get this moving red dot added or ask if it was on the roadmap myself as currently

lightburn is basically a static page while the cut is done and

The percentage/progress bar is no indication if a certain element of a cut job is done (like this was graphically shown with moving red dot in laserweb)

but then thought maybe I am I the only one missing this feature and silly to ask but also patiently waiting for the camera bit to be enabled bit as then this should relive positioning and watching the laser.

I’ve been using the FIRE LASER feature set at 0.25% happily to line up the laser and materials.

I think I’ve found a bug though:

If I have Fire Laser activated and press START to begin the job, the laser will try and cut at only 0.25%. Not 100%

We’ll split the difference on that one - the feature isn’t intended to be left on when not directly in use. A fix for it will simply be our code turning it off when you hit start.

Where is the fire laser function in Lightburn?

You have to enable it in the device preferences, then it appears on the “Move” panel.

Thanks for this, LightBurn Team.

 

Being able to know where the laser head is (And the fixed SVG import) has really helped. :slight_smile:

You’re welcome - Happy to hear it.

Have an E1 A3. The absolute coordinates are off by a good amount. Anything I burn starts 25 MM right and 15 MM north of the points drawn on the grid. Have tried every reset button, but no luck. Thanks.

Have you ever programmed a workspace offset for your machine?  What does it display if you type $# into the console?

After typing $#, I get a group of closed brackets with coordinates; they are all 0’s. I tried the position laser pointer option and touched the 0,0 origin and the laser moves to a point that is approximately 10mmX, 10mmY.

 

Have you homed the machine? The E1 requires homing when you first start LightBurn.

Yes, Followed the instructions on the web-site for upgrading to Lightburn from Cut-2d. I tried last evening to run the laser head around the perimeter of the grid on my E1 A3 (using the “point to” feature) . It is 10-12 mm to the right of the left edge and the same up from the bottom edge. The carriage runs into the upper wall and right wall without reaching the edge of the grid… 

Todd - It sounds like your machine might be missing steps. If you flip over to the ‘Move’ window (usually behind the cut layers), check to see what the speed value is there. If it’s 200 (was our old default) try changing it to 100 and see if that helps.

Alright.

First. Sorry to not have answered recently. Have been traveling for work. 

Second. Think I have this sorted. Your last suggestion cleaned up movement and kept the gantry from crashing into the upper right corner of the frame, but did not fix my positioning issue. When I first received my E1, I had laid down tape on the bed and traced a line at the maximum dimensions. I then cut metal Starret brand flexible measuring tape and laid it down to create a starting point for using the bed. When I upgraded my firmware, the position shifted; I assume that was to correct the issue with the gantry crashing into the the lower left corner of the frame when jobs were started at 0,0. I pulled up the old tape, re-laid masking, shot another rectangle at max dimensions, and laid new Starret measuring tape. Works like a treat now.

Thanks for all your patience while working through this. I’m back to burning!