Darkly Labs Community

DXF import issues with v0.7.01

I have created a DWG file in “DraftSight 2018 x64 SP1” and then saved it as a DXF ascii file. When I open the file in LightBurn, the objects are spread all over the place. 

Here’s the DXF file in question: https://drive.google.com/open?id=19HJL0tPMcGS3SjL6Y2VblE4kwgeJT7Cq

Here’s how it looks when I open it in DraftSight: https://drive.google.com/open?id=1Xmx-JRdO3xfQwEsbLZkJP9TMgD6EUAxc

Here’s how it looks in LaserBurn: https://drive.google.com/open?id=1Nro2SkEStkrzlte2ucH1tKjatohckcBi

I’m using Microsoft Windows [Version 10.0.17134.48] and Emblaser 1 A3 with V2 of the firmware.

I will try to have a look at your file this evening.

1 Like

I have also tried to create same DXF file using Solidworks 2018. 

Here’s how it looks in SolidWorks: https://drive.google.com/open?id=10k_hBh_SFvTAUoqKUBqA_WkQZB_8BYXB

Here’s the DXF file generated by SolidWorks: https://drive.google.com/open?id=1fg6UpOFeM29m9Wdf159tt3mLsqjHxVxf

Hope this helps.

 

Just because I love self-flogging, I took a look at the file too. When imported into my LB, it does the spread objects thing. When loaded into Inkscape, it does the spread objects thing. When loaded into AutoCAD, it looks marvelous.

When saved as R12 AutoCAD DXF, still spread out. When saved as ACAD 2013 AutoCAD DXF, still spread out.

When exported from AutoCAD as .EPS, LB can’t read it, but Inkscape shows it healthy, although tiny, 58 x 41 mm. If this is a wing section for a model airplane, perhaps those are good numbers.

When the Inkscape import of EPS was saved as SVG, LB opens it without problems. Curiously, Inkscape does not show layers, but when the EPS is loaded in LB, the layers return. The size remains as 58x41 approximately.

This is fixed, and will be in the next release, hopefully sometime this weekend.

image.png

Awesome!!!