Darkly Labs Community

Centering a job

Ok, excuse my lack of knowledge on this. But how do I set lightburn up so I can jog the laser to the center of a material and then start the job from there? I’ve read the manual and can se wit has to do with user origin etc but from there, where should the design be on my GUI grid? At 0,0 etc. Apologies I’ve never had to use this function before so any assistance would be appreciated.

You can place the design anywhere you like, and use the “User Origin” Start point with a center job origin:
https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md

You could also use Absolute coords as you’re used to. After jogging to where you want the job to start, click the “Get Positions” button in the Move window, then the “Show last position” button in laser window. You’ll see a crosshair where the laser is positioned. Then you can select the content of the job and click the last button on the top toolbar, “Move to Laser Position”.

Excellent thanks for that. I’ll give that a go and re-read the manual as well. I didn’t originally see the ‘move to laser position button’, I dare say that’s what I trying to figure out.

Ok so I think I’ve identified an issue, which considering no one else appears to have raise maybe it’s user error. The job origin selection does not appear to be working. The job origin selection, next to the x, y pos coordinates, are not changing when you select any position and the green box stays at the default top right position. Am I trying to change the job origin correctly to move the green box to the centre of my image as per the manual?

I’m using the latest version of light burn, on windows 10 with the Emblser 2.

That control is only for choosing the origin for resizing.  If you set it to top middle, for example, and then reduce the height of an object, it’ll be scaled from the top, instead of the center.

The job origin control you want is in the settings, on the bottom left:

 

This video may help:

https://www.youtube.com/watch?v=4gNqs4GQfjE

 

Oh I see, yep I wasn’t in that settings area. That video was great thanks for that link. I’ll play tonight. Thanks again for all your help, Lightburn is fantastic!