Can’t see E2 Camera Overlay

Yesterday I installed the E2 camera for the first time, despite the fact that I have used the Emblazer for three years without bothering. Whilst it worked I felt that I had not captured the best possible image so today started again – I wish I hadn’t. Although setting it up was difficult because I have to hold the calibration card and also do a far stretch to my laptop screen, I managed to get a reasonably satisfactory Camera Control image. I did make sure to click finished before moving onto Calibrate Camera Alignment as I assumed that settings would not otherwise be saved.

When I open the Camera Control window it does not update Overlay and neither Fade nor Show settings make any difference. I’ve played around with Auto Exposure and Brightness but it didn’t help. I have selected the E2 camera. As I had it working yesterday I’ve obviously overlooked something really basic but I’m stumped as to what to do next.

Any help much appreciated.

Lightburn 1.2.1

30 MINUTES LATER:

All is good, don’t know what is different but it is working ok.

Q. Is there any way to flip the image so that the X rail appears at the top of the overlay image rather than the bottom? As I have it, it blocks part of the image.

FURTHER FRUSTRATION:

Have worked on this calibration most of the day. I’m seeing enlarged scaling in the camera fade window and suspect it is because I went back over printing the bullseyes at darker settings. Lightburn said that this may cause scaling errors if the scale is not also reset.

Now when I attempt to click the first bullseye it shows my red registration mark but does not let me click “Next”. Aaaaaagghh!

Hi Elayne,

Regarding your most recent reply on this post: LightBurn will not let you click [Next] until each of the 4 points are clicked, in order. Once you have double click the first, LightBurn will wait for you to locate and double click the second, then third, then fourth, before [Next] is available.

Clicking the markers out of order will result in a flipped image, however the image in your screenshot appears correct.

The Gantry is visible at the rear of the virtual workspace because this matches the rear of the physical workspace. You can move the Gantry to the front of the machine using the controls in the Move tab or the ‘Click to Move’ tool, before capturing an overlay image, to prevent the Gantry blocking part of the workspace.

Please let me know if you are still having issues and we can work through it together in a support ticket.

Lliam
Customer Support Team
D A R K L Y L A B S
darklylabs.com

Thanks Lliam, understood. Have calibrated and WHEN I find the camera control it works,well but each time I close Lightburn the camera window disappears. Is there any way to pin the camera control window ON so that it is always ticked - and more importantly where does it live? I have to shut every window and hunt all over my screen to have any chance of seeing it.

Hi Elayne,

The Camera window/tab should remain wherever you place it on the screen - even between sessions of LightBurn.

You can ‘dock’ the window at the sides of the main LightBurn screen, in the same space as the Cuts / Layers, Move, and Laser tabs. To do this, simply drag the window to the edge of the screen or over another window and release when the area is highlighted.

If you are experiencing issues with windows/tabs not staying in the same location, please go to File > Open prefs folder, close LightBurn, then rename the ‘prefs.ini’ file to ‘backup_prefs.ini’ (or similar).

Following this, try restarting LightBurn. This should return your screen layout to the default setup. Make an obvious change to the window layout.
Lastly, restart the LightBurn app and see if the changes are retained.

If this process works, you can continue to setup your screen as desired and changes should be retained.
If you are still having trouble with your layout, please send the ‘prefs.ini’ file to help@darklylabs.com

~Lliam

Hi Elayne,

Don’t know if this will help, but if you need to calibrate your camera again, this Livestream walks you through the process, with a few hints on how to easily get your targeting on point.

Hope it helps :slight_smile:

-Gil

Thanks Gil, I had used your videos successfully - current issues are possibly caused by a corrupted Prefs folder. Will redo when I finish my current project.

Did you get my “Latest Project” email a couple of weeks ago? In case not, I’ll re-send.

Hope the throat is up to L-Ling next week!

Regards,

Elayne

Thanks Lliam, resettling the Prefs. file brought the camera control window back.

My new issue is that I can’t get the overlay to update as the “Update Overlay” button remains ghosted - yes, the Emblaser is on and a portion of file is selected.

Hi Elayne,
Do you have the E2 Camera selected in the Camera menu?

Thanks Domenic, yes, E2 camera is selected, Auto Exp. And Brite, Show and Fade - and I’ve nominated a selection.

I am on a new Prefs. File so maybe I’m overlooking a relevant option?

Hi Elayne,

Can you please confirm the following:

  1. That the Camera feed in the Camera window is live?
  2. That you only have a single session of LightBurn open?

Next, can you please try selecting ‘None’ from the Camera selector, then re-selecting the E2 Camera to see if this resolves the issue.

Following this, if the issue remains, please share the results of the above checks/tests in an email to help@darklylabs.com so that we can look into this further.

~Lliam

Hi Liam, you have sorted the issue - almost. The camera feed was NOT live but reselecting fixed the issue. Thank you!

The overlay seems to be showing inaccurate scaling of what I am working on. In the camera feed you can see that I have pinned down warped wood with heavy plumbers magnets (can’t remember the correct name) and set my work around them but the overlay is indicating that I will encounter disaster, which is actually not so.

I get the feeling that I need to delete the E2 camera and start all over again but that involves rearranging furniture in a very tiny bedroom, in order to be able to reach both when holding up the dotted card. At this time I’m early days into a project cutting 366 tiny pieces and since I waited three years before thinking about setting up the camera, I think I’ll wait just a bit longer.

Will deleting the existing E2 camera settings be done through Windows rather than Lightburn?

Progress!

Ok, so it looks like you might need to perform a Camera Alignment.

The alignment should be performed at the height of the material surface for best results - so on top of the cutting tray with a spacer beneath mimicking the material thickness.

This should get you pretty close in terms of accuracy, however it is worth noting that there are limitations based on the cameras location and field of view, particularly with taller support/material combinations.

~ Lliam

Ok, thanks for the info. Lliam and Domenic. I had performed the alignment (several!) using 10mm whereas these days I only use the 26mm honeycomb bed. At the rate I’m cutting, then cleaning up, sanding, painting, glueing It will be at least several weeks before I finish my current project. Once done I’ll redo the camera.

Is it ok to just relaunch a calibration or do I delete the E2 first, either somewhere thru Windows 11 or Lightburn?

Thanks once ago for the patience you have shown with me.