Darkly Labs Community

Calibrating camera lens issue

Hi,

I am trying to run the calibration of the camera lens but when I start the wizard, it moves the laser head over to the right but the gantry is in about the middle of the bed (rather than moving all the way to the front).

This means that I am unable to move the calibration card around the entire workspace.

I tried moving the gantry to the front, but as soon as I hit Capture, it moves it back to the middle.

How can I get past this?

 

Thanks

Steve

It’s not necessary to move the calibration card throughout the workspace - you only need to move it around within the camera field of view for lens calibration.

I am also having problems. When I run the calibration wizard the image that is used to calibrate the targets is not live. I have run the wizard several times and it appears to be an old stored image that is retrieved when the target alignment process is required.  Help required.

 

Cheers

Daryl

If you’d like to try it, there are new versions coming that should hopefully fix a number of the camera issues.

These are pre-release, but I’d be interested to hear if this solves your issue:

Win64: https://drive.google.com/open?id=102jiDh4ixV8CjP7f31UBumPfCUliGxpn
MacOS: https://drive.google.com/open?id=16dvMSm6qS9fv67QaShl3UJHTLcdJ7Ait

Can you tell me which OS you’re running?

WIN 10 64bit

 

I will check it out straight away and keep you posted.

 

I was already running 7.02 but I did load the version provided it the link.  I have the same issue. See the screen capture. (Still not a current valid image)

 

Try running the lens calibration again with this version and see if that helps. This is tagged as 7.02 for the moment, but you’ll notice distribute and align options are added, and the toolbar is shorter (we’ve added roll-ups).

I did run the version as per the link provided. The screen capture in my previous post was running that new version.

When I run the calibration a dot pattern is expected, Do I need this or just the 4 x targets that were printed when running the wizard?

You most certainly need the circles pattern, and to run the lens calibration.

The circles calibration image is available on this page:

https://github.com/LightBurnSoftware/Documentation/blob/master/Using_a_Camera.md

OK I will print one out.  Where does the four target file that is generated in the wizard come into play?

The circles pattern is used to determine and remove the fisheye distortion.

The 4 targets are used to compute the position and orientation of the camera relative to the bed, in real world units, and perform the inversion of that.

Be sure when you do the lens distortion calibration that the circles pattern is very flat - mounted to foam board or a piece of wood is ideal.

OK I will run it on ply.  Do I also need the chessboard pattern?

 

No, the 4 targets replaces the chessboard, and because the Emblaser generates it, we know the exact placement, making that part much more accurate and simpler.

I sort of got it done but I think I need to do another cal tomorrow in daylight. I run my E2 in a workshop where the lighting is not all that great. I think the amber lid on the E2 also inhibits the light somewhat.

With daylight the calibration went without a hitch. However, the quality of the image from the camera is not really that great. I’m not sure whether I have an issue or that’s the image quality I should expect.

Is your camera lens dirty, or the machine full of smoke after the test pattern cuts? There’s a “fade” button that makes the image transparent to help with positioning - try toggling that to see if it improves, otherwise check the camera lens itself to see if it’s clean. The image should be clearer than that.

Lens was cleaned before starting the cal process. No smoke. It could be perhaps a combination of low light and poor focus.  Turning off fade improved it a little.